quarta-feira, 13 de fevereiro de 2013


Google Disse Red Hat Enterprise Linux 6 Está Obsoleto [Updated]

Posted by Swapnil Bhartiya 11Feb2013

Google, uma das companhias lideres em open source e Linux, declarou Red Hat's RHEL 6 como obsoleta. Jan Wildeboer, um Red Hat evangelista, descobriu que Google Chrome não será mais atualizado no RHEL 6.

O Google exibiu uma notificação que diz, "Google Chrome não estará mais atualizado por que seu sistema operacional é obsoleto "

O RHEL 6 foi lançado no final de 2010; a próxima versão do RHEL, versão 7, será lançado esse ano. Então os usuários da ultima versão do RHEL não conseguem utilizar mais o Google Chrome.
Wildeboer escreve em sua página do Google+ :
Por que o Google coloca os usuários do (ao menos) Red Hat Enterprise Linux 6 em risco ao parar as atualizações para o Chrome? Enquanto continuam mantendo suporte o suporte ao Windows XP?
É  surpreendente como, mesmo que o Windowx XP que está alcançando o fim da vida tem bom suporte ao Google e distribuições GNU/Linux como Ubuntu 10.04 tem bom suporte.
Wildeboer mais tarde escreve:
nós lançamos novas versões estáveis do RHEL a cada 2-3 anos. A estabilidade da API/ABI é o que diferencia das distroscomunidade. Clientes precisam de termo de estabilidade (long term stability). O Google sabe (e utiliza) disso internamente. Ao cortar o suporte dasdistribuições  enterprise eles simplesmente me dizem para me mudar para outro lugar. Isso não é uma coisa encorajadora.
Nós alcançamos o Google e esperamos a resposta deles.
Por que o RHEL 6 não está recebendo atualizações?
O que eu aprendi das minhas fontes é que o Chrome, como nós bem sabemos, é baseado no Chromium e a comunidade por trás do Chromium gostaria de usar os novos recursos da  linguagem C++ (i.e., C++11 - muitos estão migrando para isso) por segurança e por ser mais fácil de manter. Mas suportar C++11 significar adotar uma nova corrente de ferramentas e atualizar para o GCC 4.6.

Então isso recai ao fato de que todas as versões do sistema operacional que utilizam as antigas bibliotecas C++, tal qual algumas distribuições Linux incluindo o  RHEL 6, não irão por essa rasão ter suporte depois do Chrome 26.

Essa é uma das rasões que WildeBoer viu que as notificações de atualização, em tais distribuições que vem com as bibliotecas C++ antigas tal qual RHEL, o Chrome continuará funcionando mas não serão mais atualizadas depois da versão 26. Então o Google começou a notificar os usuários no canal de desenvolvimento (o Chrome 26 estável está muitos meses fora) nesses sistemas que depois do Chrome versão 26 não terão mais suporte ao sistema.

A companhia, como eu aprendi das minhas fonte, está a vontade para trabalhar com suporte estendido ao Red Hat se possível.
 Fonte: http://www.muktware.com/5203/google-says-red-hat-enterprise-linux-6-obsolete?utm_source=feedburner&utm_medium=email&utm_campaign=Feed%3A+muktware%2Ffeeds+%28Muktware+Feeds%29

Um comentário:

  1. Essa briga de egos entre empresas, mais atrapalha do que ajuda. A google parece uma criança brigando sobre a política da distro RedHat, cada distro tem suas particularidades, assim como Debian, ambas são estáveis, então que ela disponibilize o chrome, e que a RedHat mantenha o pacote, como é no Chromiun.

    ResponderExcluir